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Introduction 

This document describes how to add a Yaskawa 1000 series AC Drive with an SI-P3 or SI-P3/V Option to a PROFIBUS 

network using the Siemens Step 7 software. Although this document refers to the SI-P3, the same steps should be followed 

for the SI-P3/V. The connections of the SI-P3 and SI-P3/V to a PROFIBUS network are identical. 

Intended Audience 

This document is intended for those involved in designing, installing and/or commissioning a PROFIBUS system including 

Yaskawa 1000 series AC Drives. It is assumed that the reader is familiar with Yaskawa 1000 Series AC Drives, PROFIBUS 

and Siemens Step 7 programming. Familiarity with the SI-P3 and SI-P3/V Options and with Yaskawa AC Drives’ installation 

guides and technical manuals is highly recommended. 

References 

Siemens documentation may be downloaded from https://support.automation.siemens.com 

49948856 SIMATIC PROFIBUS with STEP 7 

45531107 SIMATIC Programming with STEP 7 

 

Following manuals may be downloaded from  https://www.yaskawa.com  

SIEPC71061641 Yaskawa 1000 Series AC Drive Technical Manual 

TOBPC73060042 1000 Series Drive Option - PROFIBUS-DP Installation Manual SI-P3 

SIEPC73060042 1000 Series Drive Option - PROFIBUS-DP Technical Manual SI-P3 

SIEPC71060618 Yaskawa V1000 AC Drive Technical Manual 

TOBPC73060023 V1000 Option PROFIBUS-DP Installation Manual 

SIEPC73060023 V1000 Option PROFIBUS-DP Technical Manual 

 

PROFIBUS information may be downloaded from https://www.profibus.com/technology/profibus/ 
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Create a Project 

Create Project 
• Open the Step 7 software 

• Cancel the Wizard 

• Select File → New 

Name Project 
• Enter the project Name 

• Click OK to accept the entries 

Add Station 

• Select Insert → Station 

Add System Rack 
• Select station type (SIMATIC 300 Station for this example) 

• Select Object → Insert Object → Station, Rack and Rail 

Open Hardware Catalog 

Add CPU to System Rack 
• Select CPU from Catalog 

• Add the CPU to the system rack 

PROFIBUS Network Configuration 

• Enter the CPU IP Address and Subnet Mask 

• Click New 

PROFIBUS Network Name 

• General Tab 

• Enter the network Name 

PROFIBUS Network Settings 

• Network Settings Tab 

• Verify S7 subnet ID 

• Click OK 
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Create Project 

Open the Step 7 software. Only use the project wizard if your PLC can be automatically selected in the wizard.. Select New 

from the File drop down menu. The New Project dialog box will automatically be displayed. 

 

Select  

File 

 

New 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Name Project  

After the New Project dialog box is displayed, enter the name of the project in the Name box. Verify that the project 

directory is correct and Click OK. 

 

 

 

 

 

 

 

 

 

 

Enter project 

Name 
 

 

Click  

OK 

 

 

  

Figure 1 -- Create Project 

Figure 2 – Enter Project Name 
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Add Station 

A station needs to be added to the project to represent the controlling device. Select Insert from the main menu, Station from 

the subsequent menu and the appropriate station from the displayed list. The SIMATIC 300 Station is used in this example. 

 

Select  

Insert 

 

Station 

 

SIMATIC 

300 Station 

 

 

 

 

 

 

 

 

 

 

 

 

Select station SIMATIC 300 from the left frame of the main dialog box. Double Click Hardware in the right frame of the 

main dialog box. The HW Config dialog will automatically be displayed. 

 

 

 

 

Double Click  

Hardware 

 

 

 

 

 

 

 

 

 

 

 

 

  

Figure 3 -- Select Station 

Figure 4 -- Open Hardware Configuration 
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Add System Rack 

The initial HW Config dialog box should not contain any hardware. To add a system to the project hardware an object 

must be inserted to contain the CPU, power supply and any additional modules that would belong to the system. Select 

Insert from the main menu then Insert Object from the subsequent menu. 

 

Select 

Insert 

 

Insert Object 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A dialog box will automatically appear in the upper left corner of the HW Config dialog. Select the appropriate station 

(Station 300 in this example). Select Rack and then Rail from subsequent menus. A station configuration dialog box 

representing the system rack will automatically be displayed. 

 

 

 

 

Select 

Station 
 

Rack 
 

Rail 
 

 

 

 

 

 

 

 

  

Figure 5 -- Insert CPU Object 

Figure 6 -- Define Inserted Object Type 
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Open Hardware Catalog 

The CPU and subsequent hardware modules and devices must be selected from the hardware catalog. If the catalog is not 

open, select View from the main menu and Catalog from the View menu.  

 

Select 

View 

 

Catalog 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Add CPU to System Rack 

Select the CPU and firmware version from the catalog and drag the selection to the highlighted slot in the system rack. This 

example uses a 315 2 DP V2.6 CPU. When the CPU is inserted in the rack, the network configuration dialog will open. 

 

Your CPU may be different and require additional hardware; power supply, input, output, analog modules, etc. Additional 

modules should also be selected from the hardware catalog and similarly dragged to their appropriate slot in the system rack. 

 

 

 

 

Select  

CPU 
 

Drag ( ) 

The CPU to the 

Designated slot in  

The system rack 

 

 

 

 

 

 

 

  

Figure 8 -- Add CPU to System Rack 

Figure 7 – Open Catalog 
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PROFIBUS Network Configuration 

Configuring a PROFIBUS network in a PROFINET/PROFIBUS enabled CPU is slightly different than for a PROFIBUS 

only CPU and shown in this example. See Appendix B for an example of configuring a PROFIBUS network on a 

PROFINET/PROFIBUS enabled CPU. 

 

Select the CPU’s node Address on the PROFIBUS network. Click New to add a network to the CPU. 

 

 

 

 

Select 

CPU Address 

 

 

Click 

New 

 

 

 

 

 

 

 

 

 

PROFIBUS Network Name 

At the General tab, enter a network Name and verify the S7 subnet ID. Optionally, enter the project Author and project 

Comments. Select the Network Settings tab to continue with the network configuration. 

 

Enter Network 

Name 
 

 

 

 

Verify 

S7 subnet ID 

 

Optionally Enter 

Author 

 

Comments 
 

 

 

 

 

  

Figure 9 – Select Node Number 

Figure 10 – Define PROFIBUS Network 
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PROFIBUS Network Settings 

Verify the network Highest PROFIBUS Address, Transmission Rate and Profile. Click OK to accept the settings. 

 

Verify 

Highest 

PROFIBUS 

Address 

 

 

 

 

Network 

Transmission 

Rate 
 

 

Profile 

 

Click 

OK 
  

Figure 11 – Verify PROFIBUS Network Settings 
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Add an SI-P3 PROFIBUS Option 

Install GSD File 

• Select Options → Install GSD File from the sebsequent menu 

• Browse for the SI-P3 GSD file location 

• Select the SI-P3 GSD file 

• Select Install 

• Click Close 

Add SI-P3 Option 

• Select SI-P3 from the hardware catalog 

• Add the SI-P3 

Configure SI-P3 Network Connection 

• Select node address 

• Select network subnet for connection 

Add Cyclic IO 

PPO Types Supported 

Select PPO 

• Select the SI-P3 IO telegram 

• Add the selected telegram 

Add Symbols to IO 

PPO Telegram Header Symbols 

• Select IO area 

• Select Edit Symbols 

• Enter symbols 

• Apply edits 

Control & Status Word Symbols 

• Select IO area 

• Select Edit Symbols 

• Enter symbols 

• Apply edits 

Download Hardware Configuration 

Save and Compile 

• Select Station → Save and Compile 

Download to PLC 

• Select PLC → Download 

• Close the HW Config dialog 
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Install GSD File 

The SI-P3 and SI-P3/V use the same GSD file. If the file has not already been installed, select Options from the main menu, 

then Install GSD File from the subsequent menu. 

 

Select 

Options 

 

 

 

 

Install GSD File 

 

 

 

 

 

 

 

 

 

 

 

 

 

Browse for the SI-P3 GSD file’s location, select YASK0ACF.gsd then Install. Click Close after the file has been installed to 

return to the HW Config dialog. 

 

Select 

GSD File 

Location 

 

 

GSD File 

 

 

 

 

 

Click 

Install 
 

 

Close 

 

 

  

Figure 12 -- Install GSD File 

Figure 13 -- Select SI-P3 GSD File 
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Add SI-P3 Option 

Select the SI-P3 PROFIBUS-DP from the hardware catalog. It is located under PROFIBUS DP → Additional Field 

Devices → Drives → SI-P3 in the hardware catalog. Drag the selection to the PROFIBUS network.  

 

 

 

 

 

 

 

Select  

SI-P3 

Drag ( ) 

The SI-P3 to the 

PROFIBUS network 

 

 

 

 

 

 

 

 

 

Configure SI-P3 Network Connection 

To add the SI-P3 to the network, select the node Address assigned to the SI-P3. Note that no two devices on the same subnet 

may have the same node Address. Select the network connection from the list of Subnets. This should be the same network 

that was created for the installed CPU. Click OK to accept the selections. 

 

Select 

Node Address 

 

 

 

 

Network Connection 

Subnet 

 

 

 

 

Click 

OK 

 

 

  

Figure 14 -- Add SI-P3 Drive to Network 

Figure 15 – Configure SI-P3 Network Connection 
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Add Cyclic IO 

PPO Types Supported 

The table below shows the PPO types supported by the SI-P3. The PPO Type sections are shown as WORDs. Notice that 

PPO Types 3 and 4 do not support the PPO header. 

 

Since PPO Type 1 is used in this example, the WORD addresses assigned by adding the SI-P3 Option to the network are 

shown below the PPO Type 1 header section names. Notice that each section begins on even byte boundaries. 

Table 1 - Supported PPO Types 

PKW PZD 

PKE IND PWE PZD 1 PZD 2 PZD 3 PZD 4 PZD 5 PZD 6 PZD 7 PZD 8 PZD 9 PZD 10 

 

PPO Type 1 

PKE IND PWE PZD 1 PZD 2 

256 258 260 262 264 266 

 

PPO Type 2 

PKE IND PWE PZD 1 PZD 2 PZD 3 PZD 4 PZD 5 PZD 6 

          

 

PPO Type 3 

 PZD 1 PZD 2 

   

 

PPO Type 4 

 PZD 1 PZD 2 PZD 3 PZD 4 PZD 5 PZD 6 

       

 

PPO Type 5 

PKE IND PWE PZD 1 PZD 2 PZD 3 PZD 4 PZD 5 PZD 6 PZD 7 PZD 8 PZD 9 PZD 10 
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Select PPO 

Select the SI-P3 Option connected to the PROFIBUS network. From the list of telegrams supported by the SI-P3 Option 

in the catalog, select the telegram to be used for cyclic communications (PPO Type 1 in this example) and drag it to the 

highlighted slot in the in the device table located at the bottom of the HW Config dialog.. 

 

 

 

 

Select 

PPO Type 

 

 

 

Drag ( ) 

The selection to 

The device Table 

 

 

 

 

 

 

 

 

 

PPO Type 1 telegram’s IO is split into the telegram header (PKE, IND, PWE)and the data (STW/ZSW, HIW/HSW). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Figure 17 -- Cyclic I/O Properties 

Figure 16 -- Add Cyclic I/O 
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Add Symbols to IO 

Right click on the IO area in the device table that is to receive symbol representation. The PPO Type 1 4AX section was 

selected in the example below. Select Edit Symbols from the subsequent menu. 

 

 

 

 

 

 

 

 

 

 

 

 

Select 

Edit Symbols 

 

 

 

 

 

 

 

 

 

 

 

PPO Telegram Header Symbols 

In the dialog that appears after selecting Edit Symbols above, enter the symbol for the IO point in the Symbol 

column. In the example below comments were also added to the IO point. When all symbols have been entered, 

click on Apply to accept the entries. After the symbols have been applied, the Cancel button will change to Close. 

Click on Close to return to the HW Config dialog. 

 

 

 

 

Enter 

Symbols 

 

 

 

 

Click 

Apply 

 

 

Close 
 

 

 

  

Figure 18 – Edit Symbols 

Figure 19 – PPO Telegram Header Symbols 
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Control & Status Word Symbols 

Follow the same steps as described in the PPO Header section above for adding symbols to the Control and Status 

Words. 

 

 

 

 

 

Enter 

Symbols 

 

 

Click 

Apply 
 

 

Close 

 

 

 

 

 

 

 

Note: Symbols reside on the Step 7 programming device and are not stored in CPU memory. 

  

Figure 20 – Control & Status Word Symbols 
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Download Hardware Configuration 

Save and Compile 

Once all of the devices have been added to the network and configured, the information must be compiled and 

downloaded to the PLC. Select Station from the main menu then Save and Compile from the subsequent menu. 

 

Select 

Station 

 

 

Save and 

Compile 

 

 

 

 

 

 

 

 

 

 

 

 

Download to PLC 

After the project hardware has been saved and compiled, download it to the PLC. Select PLC from the main menu and 

Download from the subsequent menu. After the program has been downloaded to the PLC, close the HW Config dialog. 

 

Select 

PLC 

 

Download 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Figure 21 -- Save and Compile 

Figure 22 -- Download to PLC 
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Drive Control via. Variable table 

Variable Table 
Create Variable Table 

• Select Insert → S7 Block → Variable Table 

Name Variable Table 
• Enter a Symbolic name (SI-P3 IO in this example) 

• Click OK 

Populate Variable Table 
• All inputs and outputs are of data type WORD and begin on even BYTE boundaries 

Input Variables 
• Inputs are entered as PIW [Address] 

Output Variables 
• Outputs are entered as PQW [Address] 

Monitor Input Variables 
• Press Ctrl+F7 on the keyboard or 

• Select Variable from the main menu 

• Select Monitor from the subsequent menu 

Drive Control 

Base Block 

• Set Control Word to 0Fh 

Drive Run 
• Set Control Word (STW) to W#16#7F 

• Set Data Word to (HSW) W#16#1770 

Drive Parameters 

Write to C1-01 (Accel 1) 
• Set PKE to W#16#701F 

• Set IND to W#16#1 

• Set PWE (LSW) to W#16#64 

Read Manufacturer’s Coding 
• Set PKE to W#16#63C4 

• Set IND to W#16#1 

Read U1-01 (Frequency Reference) 
• Set PKE to W#16#60D# 

• Set IND to W#16#1 
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Variable Table 

Create Variable Table 

From the project’s main screen select Insert from the main menu, S7 Block then Variable Table from subsequent 

menus. 

 

Select 

Insert 

 

S7 Block 

 

Variable 

Table 
 

 

 

 

 

 

 

 

 

 

 

Name Variable Table 

Once the variable table has been added, it should be named. Enter a Symbolic Name for the table and Click OK to 

accept the entry. 

 

Enter 

Symbolic 

Name 

 

 

 

 

 

 

 

 

 

 

Click  

OK 

 

 

  

Figure 23 -- Create Variable Table 

Figure 24 -- Name the Variable Table 
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Populate Variable Table 

Input Variables 

Once created, the variable table needs to be populated with the variables that are to be monitored and/or modified. 

This example uses all of the input and output words of the chosen cyclic IO telegram.  

 

Select Insert from the main menu and Range of Variables from the subsequent menu. 

 

Select 

Insert 

 

Range of 

Variables 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

From the dialog shown after the Range of Variables has been selected, enter the address of the first variable in the 

range of inputs. Enter the number of variables included in the range and the data display data type. Click OK to 

accept the data entered. 

 

Inputs are prefaced by PIW. All inputs are of data type Word (16 bits) and begin on even BYTE boundaries. 

 

Enter 

Starting 

Address 

 
Select 

Number 

of 

Variables 

 

Display 

Format 
 

Click 

OK 

 

 

  

Figure 25 -- Populate Variable Table - Inputs 

Figure 26 -- Set Table Input Range 



Using the Yaskawa PROFIBUS Option SI-P3 or SI-P3/V with Siemens Step 7 Software 

12 July 2018. Document: AN.AFD.30 Page 20 

Output Variables 

Select Insert from the main menu and Range of Variables from the subsequent menu to add outputs to the list. 

 

From the dialog shown after the Range of Variables has been selected, enter the address of the first variable in the 

range of outputs. Enter the number of variables included in the range and the data display data type. Click OK to 

accept the data entered. 

 

Outputs are prefaced by PQW. All outputs are of data type Word (16 bits) and begin on even BYTE boundaries. 

 

Enter 

Starting 

Address 

 

Select 

Number 

of 

Variables 

 

Display 

Format 
 

Click 

OK 

 

 

 

 

 

Monitor Input Variables 

To monitor the input variables, simultaneously press Ctrl + F7 or select Variable from the main menu and Monitor 

from the subsequent menu. 

 

Select 

Variable 

 

Monitor 
 

Inputs 

 

 

 

 

Outputs 

 

 

 

 

 

  

Figure 27 -- Set Table Outputs Range 

Figure 28 – Monitor Input Variables 

PKE 

IND 

PWE (MSW) 

PWE (LSW) 

PZD1 (ZSW) 

PZD2 (HIW) 

 

PKE 

IND 

PWE (MSW) 

PWE (LSW) 

PZD1 (STW) 

PZD2 (HSW 
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Drive Control 

Base Block 

Base Block removes any output to the motor terminals, removes any Run command and sets the Frequency 

Reference to 0.00Hz . Since the PPO Control Word is initially all zeros, the drive will power up in Base Block 

(bb). To remove Base Block set the first byte of the Control Word to Fh (15d). Refer to Control and Status Words 

below. 
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Drive Run 

To control the attached drive, modify the Control and Data Word output values. Enter the Control Word value 

W#16#7F (127d) (Run command) in the Modify value column for output “A1 Control Word”. Enter the Data 

Word value W#16#1770 (6000d) (frequency reference) in the Modify value column of output “A1 Freq Ref 

Cmd”. Press the F9 key on the keyboard to send the modified values to the drive. 

 

 

 

 

 

 

 

 

 

 

Enter 

Control 

Word 

 

Data 

Word 

 

  
Figure 30 – Run Drive 

Figure 29 – Remove Base Block Variable Table 
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Drive Parameters 

Write to C1-01 (Accel 1) 

To access drive parameters the telegram header must be modified. To write to parameter C1-02 

 Set PKE to 701Fh 

  The Task ID is 7 which is Write Parameter in Array (WORD) 

  The PNU is 1Fh which is the array designation for C1 Category. 

 Set IND to 1, the array offset for C1-01 

 Set PWE to 64h to set C1-01 to 10.0Hz 

If the write is successful, the Response ID will be 4 as shown for “A1 In PKE” below.. It will be 7 if the write was 

not successful. 
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Read Manufacturer’s Coding 

To read the manufacturer’s coding, 

Set PKE to 63C4h. 

 Task ID is 6 which is Read A Parameter Value From An Array (WORD) 

 The PNU is 3C4h (964) see Supported PNUs below. 

Set IND to 1, the array offset for the first member of the array, Manufacturer’s Coding. 

 

The response will be returned in “A1 Status Word”. If the Response ID is 4### the response is valid. If the 

Response ID is 7### the response is invalid. 
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Figure 31 – Write Value to C1-01 
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Figure 32 – Read Manufacturer’s Coding 
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Read U1-01 (Frequency Reference) 

U1-01 contains the current Frequency Reference for the drive. To read U1-01, 

Set PKE to 60D3h. 

 Task ID is 6 which is Read A Parameter Value From An Array (WORD) 

 The PNU is D3h (211) which is the array designation for the U1 Category. 

Set IND to 1, the array offset for the first member of the array, U1-01. 

 

The response will be returned in “A1 IN PWE (LSW)”. If the Response ID is 4### the response is valid. If the 

Response ID is 7### the response is invalid. 
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Figure 33 – Read U1-01 
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Ladder Logic (LAD) Programming Examples 

Drive Control 

Run the Drive 
• One shot a move of W#16#7F to “A1 Control Word” and W#16#1770 to “A1 Freq Ref Cmd” 

Stop the Drive 
• One shot a move of W#16#0 to “A1 CONTROL WORD” and W#16#0 to “A1 Freq Ref Cmd” 

Read Parameter C1-01 (Accel 1) 

Verify Parameter Read 

• Shift “A1 In PWE (LSW)” twelve bits right. 

• Compare shifted word to 4 
Write Parameter Read Command to Drive 

• One shot a move of W#16#701F to “A1 Out PKE”, W#16#1 to “A1 Out IND” and W#16#64 to “A1 Out 

PWE (LSW)” 

Write C1-01 (Accel 1) 

Verify Write Command 

• Shift “A1 In PWE (LSW)” twelve bits right. 

• Compare shifted word to 4 

Write Parameter Command 
• One shot a move of W#16#701F to “A1 Out PKE”, W#16#1 to “A1 Out IND” and W#16#64 to “A1 Out 

PWE (LSW)” 

• One shot a move of W#16#701F to “A1 Out PKE”, W#16#1 to “A1 Out IND” and W#16#64 to “A1 Out 

PWE (LSW)” 

Write Enter RAM & Enter ROM Commands 
• Enter RAM (Accept) - One shot a move of W#16#212C to “A1 Out PKE” 

• Enter ROM (Enter) - One shot a move of W#16#212CD to “A1 Out PKE” 
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Drive Control 

Run the Drive 

The example below shows that when enable contact (M1.0) is true and the positive edge triggered one shot (M2.0) is 

true, the drive control and frequency reference are moved to the Control and Data Words, “A1 Control Word” and 

“A1 Freq Ref Cmd” respectively.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Stop the Drive 

This second circuit shows that if the moves are not enabled, the run command is removed and zero frequency reference 

is sent to the drive. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Figure 34 – Basic Drive Control Program – Run @ 60.00Hz 

Figure 35 – Basic Drive Control Program – Stop Drive 
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Read Parameter C1-01 (Accel 1) 

To read a parameter, the command for the device to respond with a parameter value must be written to the device. The actual 

parameter read circuit precedes but is dependent on the write circuit. This is to allow the device some time to respond to the 

write command. 

Verify Parameter Read 

Network 1 stores the value read and checks the Response ID for validity. If the Response ID is greater than 4, a fault is 

declared (M1.2). If the Response ID is 4, the value returned is valid and the write sent bit is reset. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Figure 36 – Verify Parameter C1-01 Read 
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Write Parameter Read Command to Drive 

Network 2 is the command to the device to return the parameter value. The first MOVE block shows moving PKE and 

IND to the telegram header. The Task ID is 6 signifying a Read Parameter from Array (WORD) command. The array 

designation (the PNU) is 1Fh (31), C1 Category. Refer to the Standard Drive Parameters table below for supported 

drive parameter PNUs. IND is 1 signifying that the first element of the array is to be read (C1-01). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Figure 37 – Command to Read Parameter C1-01  
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Write C1-01 (Accel 1) 

The format of a parameter write is the same as for a parameter read. With the Task ID and the Data area changed. The 

validity of the parameter write should be checked. 

 

Run operative and non-run operative parameters are available for writing. Refer to the appropriate drive technical manual for 

information on run operative and non-run operative parameters. 

• Run operative parameters become active as soon as they are written to the drive. If not followed by an Enter ROM 

command, they will be overwritten on a drive power cycle. 

• Non-run operative parameters are only made active if followed by either an Enter RAM or Enter ROM command. 

If followed by an Enter RAM command, the parameter value will be over written on drive power cycle. 

Verify Write Command 

The verification precedes the write command but is controlled by it. This is to allow some time for the response. 

Network 1 below shows how the command written is verified. The Response ID is stored in MW1. MW1 is then 

compared to 4. If the Response ID is greater than 4, the write command failed and an error is set (M1.2). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Figure 38 – Verify Parameter C1-01 Write  
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Write Parameter Command 

Network 2 is the command to write the parameter value to the device. The first MOVE block shows moving PKE and 

IND to the telegram header. Task ID is 7 signifying a Write Parameter to Array (WORD) command. The array 

designation (the PNU) is 1Fh (31), C1 Category. Refer to the Standard Drive Parameters table below for supported 

drive parameter PNUs. IND is 1 signifying that the first element of the array is to be read (C1-01). The PWE data to be 

sent, is 64h (100) which changes the Accel 1 time to 10.0 seconds. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  
Figure 39 – Command to Write 100 to Parameter C1-01  
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Write Enter RAM & Enter ROM Commands 

The Enter RAM command transfers the parameter values written to the drive to active RAM. The values are not saved and 

are overwritten on a power cycle. The Enter ROM command transfers the values written to active RAM but also stores them 

to NVRAM. Parameter values followed by an Enter ROM command will not be reset on power cycle. 

 

The command to write an Enter RAM command to the drive uses Task ID to 2 to Write a Parameter (WORD) and the PNU 

to the reference for Enter RAM Command, 12Ch (300). The IND and PWE are ignored. 

 

The same steps as used in the Enter RAM command are used for the Enter ROM command. The only difference is that the 

Enter ROM command PNU is 12Dh (301). 

 

Refer to Standard Drive Parameters table below for information on parameter PNUs. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Figure 40 – Write Enter RAM & Enter RAM Commands 
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Appendix A 

Anatomy of PPO Type 1 

Control and Status Words 

PROFIdrive Control Word (STW) 

PROFIdrive Status Word (ZSW) 

Task and Response IDs 

Task ID 

Response ID 

Supported PNUs 

Parameter Reference 

Control and Status Parameters 

Standard Drive Parameters 
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Anatomy of PPO Type 1 

The table below describes the allocated memory (256…267) for PPO Type 1 used in this document’s example. Those 

variables prefaced by PIW are inputs to the CPU while those prefaced by PQW are CPU outputs. 

Table 2 - PPO Type 1 Produce 

Variable Symbol Names Name Bits Description 

“A1 In PKE” PKE 

0 ~ 10 PNU 

11 0 

12 ~ 15 Task ID  

“A1 In IND” IND 0 ~ 15 Parameter Sub-Index Word 

“A1 IN PWE (MSW)” 
PWE 0 ~ 31 Parameter Write Data 

“A1 IN PWE (LSW)” 

“A1 Status Word” PZD1 0 ~ 15 Control Word (STW) 

“A1 Actual Speed” PZD2 0 ~ 15 Data (HSW) 

 

Table 3- PPO Type 1 Consume 

Variable Symbol Names Name Bits Description 

“A1 Out PKE” PKE 

0 ~ 10 PNU 

11 0 

12 ~ 15 Response ID 

“A1 Out IND” IND 0 ~ 15 Parameter Sub-Index Word 

“A1 Out PWE (MSW)” 
PWE 0 ~ 31 Parameter Read Data 

“A1 Out PWE (LSW)” 

“A1 Control Word” PZD1 0 ~ 15 Status Word (ZSW) 

“A1 Freq Ref Cmd” PZD2 0 ~ 15 Data (HIW) 

Control and Status Words 

PROFIdrive Control Word (STW) 

Table 4 - Control Word 

Bit(s) Name Value Description 

0 OFF 1 Reserved 

1 OFF 2 Reserved 

2 OFF 3 Reserved 

3 OPERATION_ENABLE 
0 Stop & Baseblock 

1 Not Baseblock 

4 RAMP_OUT_ZERO 
0 Stop 

1 Run 

5 Ramp Function Reserved 

6 Ramp Enable Reserved 

7 RESET 
0  

0→1 0 to 1 Transition Resets 

8 INCHING_1 
0 Stop 

1 Jog FWD 

9 INCHING_2 
0 Stop 

1 Jog REV 

10 REMOTE 
0 Local Control 

1 Remote Control (PROFIBUS-DP) 

11 

Reserved 

12 

13 

14 

15 
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PROFIdrive Status Word (ZSW) 

Table 5 - Status Word 

Bit(s) Name Value Description 

0 RDY_ON Reserved (Always 1) 

1 RDY_RUN Reserved (Always 1) 

2 RDY_REF 
0 Not Ready 

1 Ready 

3 TRIPPED 
0 No Fault 

1 Fault 

4 OFF2_STA Reserved (Always 1) 

5 OFF3_STA Reserved (Always 1) 

6 SWC_ON_INHIB Reserved (Always 0) 

7 ALARM 
0 No Alarm 

1 Alarm 

8 AT_SETPOINT 
0 Not at Set Point 

1 At Set Point 

9 REMOTE 
0 Local Control 

1 Remote Control (PROFIBUS-DP) 

10 

Reserved 

11 

12 

13 

14 

15 

Task and Response IDs 

Task ID 

Table 6 - Task ID 

ID Description 

0 No Action 

1 Read Parameter Value 

2 Write Parameter Value (WORD) 

3 Write Parameter Value (DBL WORD) 

4 Reserved 

5 Reserved 

6 Read Parameter Value From Array 

7 Write Parameter Value in Array (WORD) 

8 Write Parameter Value in Array (DBL WORD) 

9 Read Number of Array Elements 

Response ID 

Table 7 - Response ID 

ID Description 

0 No Action 

1 Transfer Parameter Value (WORD) 

2 Transfer Parameter Value (DBL WORD) 

3 Transfer Parameter Array Value 

4 Transfer Parameter Array Value (WORD) 

5 Transfer Parameter Array Value (DBL WORD) 

6 Transfer Number of Array Elements  

7 Task Error 
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Supported PNUs 

Table 8 - Supported PNU(s) 

PNU R/W Function 

900 (384h) W PPOI 1 

901 (385h) W PPO 2 

902 (386h) W PPO 3 (DP V1 Only) 

903 (387h) W PPO 4 (DP V1 Only) 

904 (388h) W Current PPO 

905 (389h) W PPO 5 

907 (38Bh) R PPOI 1 

908 (38Ch) R PPO 2 

909 (38Dh) R PPO 3 (DP V1 Only) 

910 (38Eh) R PPO 4 (DP V1 Only) 

911 (38Fh) R Current PPO 

912 (390h) R PPO 5 

915 (393h) R/W Assign MODBUS Write Command to PZD in PPO Write 

916 (394h) R/W Assign MODBUS Response to PZD in PPO Read 

918 (396h) R Node Address 

947 (3B3h) R Fault Number 

948 (3B4h) R Elapsed Time at Fault 

963 (3C3h) R Baud Rate 

964 (3C4h) R 

Device Identification Values 

 1: Manufacturer 273 

 2: Device Type 1 

 3: Version 0 

 4: Firmware Data (yyyy) 2007 

 5: Firmware Date (dd/mm) 0220 

 6: Number of Drive Objects 1 

965 (3C5h) R Profile Code (0x0302) 

967 (3C7h) R/W V2 Control Word 

968 (3C8h) R V2 Status Word 

971 (3CBh) R/W 0 to 1 Transition Saves to NVRAM 
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Parameter Reference 

Control and Status Parameters 

Table 9 - Control and Status Parameters 

Control Words  Status (Monitor) Words 

DPV0 PNU Modbus Address Index  DPV0 PNU Modbus Address Index 

0 0001h 1  0 0020h 32 

0 0002h 2  0 0021h 33 

0 0007h 7  0 0022h 34 

0 0009h 9  0 0023h 35 

0 000Ah 10  0 0024h 36 

0 000Fh 15  0 0025h 37 

0 0010h 16  0 0026h 38 

0 0011h 17  0 0027h 39 

    0 0028h 40 

    0 0029h 41 

    0 002Ah 42 

    0 002Bh 43 

    0 002Ch 44 

    0 002Dh 45 

    0 002Eh 46 

    0 002Fh 47 

    0 0030h 48 

    0 0031h 49 

    0 0032h 50 

    0 0033h 51 

    0 0034h 52 

    0 
. 

. 

. 

. 

. 

. 

    0 00FFh 255 

Standard Drive Parameters 

Table 10 - Standard Drive Parameters 

DPV0 PNU Category Index DPV0 PNU Category Index DPV0 PNU Category Index 

11 (0Bh) A1  01–99 52 (34h) E2 01–99 141 (8Dh) n1  01–99 

12 (0Ch) A2  01–99 53 (35h) E3 01–99 142 (8Eh) n2  01–99 

21 (15h) b1  01–99 54 (36h) E4 01–99 143 (8Fh) n3  01–99 

22 (16h) b2  01–99 55 (37h) E5 01–99 146 (92h) n6  01–99 

23 (17h) b3  01–99 61 (3Dh) F1 01–99 148 (94h) n8  01–99 

24 (18h) b4  01–99 66 (3Eh) F6 01–99 151 (97h) o1  01–99 

25 (19h) b5  01–99 67 (3Fh) F7 01–99 152 (98h) o2  01–99 

26 (1Ah) b6  01–99 81 (51h) h1 01–99 153 (99h) o3  01–99 

28 (1Ch) b8  01–99 82 (52h) h2 01–99 154 (9Ah) o4  01–99 

31 (1Fh) C1  01–99 83 (53h) h3 01–99 171 (abh) q1  01–99 

32 (20h) C2  01–99 84 (54h) h4 01–99 181 (B5h) r1  01–99 

33 (21h) C3  01–99 85 (55h) h5 01–99 201 (C9h) T1  01-99 

34 (22h) C4  01–99 86 (56h) h6 01–99 211 (D3h) U1  01–99 

35 (23h) C5  01–99 121 (79h) L1 01–99 212 (D4h) U2  01–99 

36 (24h) C6  01–99 122 (7Ah) L2 01–99 213 (D5h) U3  01–99 

41 (29h) d1  01–99 123 (7Bh) L3 01–99 214 (D6h) U4  01–99 

42 (2Ah) d2  01–99 124 (7Ch) L4 01–99 215 (D7h) U5  01–99 

43 (2Bh) d3  01–99 125 (7Dh) L5 01–99 216 (D8h) U6  01–99 

44 (2Ch) d4  01–99 126 (7Eh) L6 01–99 218 (DAh) U8  01–99 

47 (2Fh) d7  01–99 127 (7Fh) L7 01–99 300 (12Ch) RAM Enter 0 

51 (33h) E1  01–99 128 (80h) L8 01–99 301 (12Dh) ROM Enter 0 
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Appendix B – 315 2 PN/DP CPU 

Add 315 2 PN/DP CPU 

Configure CPU 

Add a Network 

Network Name and Interface Type 

Add the PROFIBUS Network 

General Tab 

Network Settings Tab 
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Add 315 2 PN/DP CPU 

Select the CPU and firmware version from the catalog and drag the selection to the highlighted slot in the system rack. This 

example uses a 315 2 PN/DP V2.6 CPU. When the CPU is inserted in the rack, the network configuration dialog will open. 

 

Your CPU may be different and require additional hardware; power supply, input, output, analog modules, etc. Additional 

modules should also be selected from the hardware catalog and similarly dragged to their appropriate slot in the system rack. 
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Configure CPU 

After the CPU has been selected ad dragged to the system rack, the Properties dialog will appear automatically. Enter the IP 

address and Subnet mask that had been assigned to this station. The IP address is 192.168.2.1 and the Subnet mask is 

255.255.255.0 in this example. Click OK to save the CPU configuration. 
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Figure 42 -- Add CPU IP Address an Subnet Mask 

Figure 41 -- Add CPU to System Rack 
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Add a Network 

Right click on the PROFIBUS connection (MP/DP) in the system rack and select Object Properties from the subsequent 

menu. 
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Network Name and Interface Type 

Enter a Name for the network and select PROFIBUS as the Interface Type. Click on Properties to configure the 

PROFIBUS network. 
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Figure 43 – Edit CPU Connection Object Properties 

Figure 44 – Select Network Name and Type 
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Add the PROFIBUS Network 

From the Parameters tab add the node Address of the CPU. Click on New to add a PROFIBUS network. 

 

Enter node 

Address 

 

 

 

Click 

New 

 

 

 

 

 

 

 

 

 

 

General Tab 

From the General tab, enter a Name for the network and verify the S7 subnet ID. The project Author and/or 

Comments may also be entered. Select the Network Settings tab. 
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Figure 45 – Add PROFIBUS Network 

Figure 46 – PROFIBUS Network Description 
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Network Settings Tab 

In the Network Settings tab, verify the maximum node number, Transmission Rate and Profile of the network Click 

on OK to accept the settings. Return to the hW Config dialog. 

 

 

Verify 

highest node 

Address 

 

 

 

Transmission 

Rate 

 

Profile 

 

 

 

Click 

OK 

 

 

  

Figure 47 -- PROFIBUS Network Settings 
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Notes 
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